Back
Maintenance

System upgrade

Completed 2 May at 09:45pm EEST.

Website (iabilet.ro) Whitelabels
Updated

All done!

Posted 2 May at 10:09pm EEST.
Completed

Maintenance completed

Posted 2 May at 09:45pm EEST.
Updated

Still working on it

Posted 2 May at 09:08pm EEST.
Updated

Sorry, it takes a little bit longer than expected.

Posted 2 May at 08:11pm EEST.
Started

We're doing some under-the-hood upgrades. Stay tuned ;)

Posted 2 May at 06:00pm EEST.